CPS Maintenance Two
Resolved
Jul 14, 2026 at 5:00am UTC
Maintenance ended
Affected services
Created
Jul 14, 2026 at 4:30am UTC
Maintenance Date has changed from Tuesday 7th July to Tuesday 14th July:
On Tuesday 14th July, between 04:30 and 05:00 UTC, essential planned maintenance will take place resulting in a brief outage of the Payter Cloud Payment Service (CPS).
For more information, please review the detailed section on the Payter Documentation Portal at the link below.
Visit the Documentation Portal [https://docs.payter.com/docs/maintenance-cps-two]
We'd also recommend registering for service notifications at the Payter Status page here:
View Payter Status [https://status.payter.com/]
Kind Regards,
Payter
Affected services