Back to overview
Degraded
MyPayter Degraded
May 15, 2026 at 9:50am UTC
Affected services
MyPayter
Resolved
May 15, 2026 at 10:16am UTC
RESOLVED
The MyPayter portal has resumed to normal operation.
Affected services
Created
May 15, 2026 at 9:50am UTC
We are aware that the MyPayter portal is currently experiencing an issue reporting transactions.
Our engineers are investigating.
Affected services