Back to overview
Degraded

CPS and MyPayter Service Degraded

May 14, 2026 at 7:01am UTC
Affected services
Cloud Payment Service
MyPayter

Resolved
May 14, 2026 at 8:17am UTC

Engineers have observed full system recovery and the platform has returned to normal operation.

Updated
May 14, 2026 at 7:35am UTC

We are continuing to monitor and investigate the platform.

Created
May 14, 2026 at 7:01am UTC

DEGRADED - We are aware of an issue that will be affecting some terminals using our our Cloud Payment Service and a potential delay in reporting for the MyPayter Portal, our engineers are currently investigating the cause.