MyPayter - Terminal Update Delays
Resolved
May 7, 2026 at 10:00am UTC
RESOLVED: Engineers have not observed any further issues, and the platform is operating at normal levels.
Affected services
Updated
May 7, 2026 at 9:44am UTC
The platform has returned to normal operating levels, the issues with terminal updates have been resolved, and engineers continue to monitor for any further errors.
Affected services
Updated
May 7, 2026 at 9:00am UTC
A fix has been implemented, and Engineers are actively monitoring the platform while the backlog of requests is processed.
Affected services
Updated
May 7, 2026 at 8:11am UTC
Engineers have identified the cause and are actively working to implement a fix.
Affected services
Created
May 7, 2026 at 7:57am UTC
We are currently experiencing issues with terminal updates, Engineers are investigating and will provide a further updates as soon as possible.
Affected services