Back to overview
Degraded

CPS and MyPayter service degraded

May 6, 2026 at 12:18pm UTC
Affected services
Cloud Payment Service
MyPayter

Resolved
May 6, 2026 at 4:21pm UTC

RESOLVED: We have confirmed that all platform components impacted during the incident have recovered and service levels have returned to normal.

Updated
May 6, 2026 at 4:02pm UTC

We are now observing positive signs that the platform has recovered, and terminal connectivity has been restored. We will continue to monitor the platform closely.

Updated
May 6, 2026 at 3:40pm UTC

We are observing that the platform is beginning to recover, and terminal connectivity is slowly being restored.

Updated
May 6, 2026 at 3:04pm UTC

A key component for CPS has to be restarted to resolve the problem. There will be some downtime for all terminals using the CPS service while this takes place.

Updated
May 6, 2026 at 2:31pm UTC

Engineers are continuing to investigate the ongoing incident and are attempting to implement a work around for the impacted terminals.

Updated
May 6, 2026 at 2:02pm UTC

We have received reports of additional issues impacting some terminals, including MyPayter reporting incorrect statuses and updates failing on certain terminals. Further investigation is currently underway.

Updated
May 6, 2026 at 12:41pm UTC

The Cloud Payment Service has been restored and is now operating normally.
We will continue to monitor the service closely to ensure stability.

Created
May 6, 2026 at 12:18pm UTC

We have identified an issue that will be affecting a small set of terminals connecting to the CPS service.
Our engineers are working on a fix now.