CPS performance issues
Resolved
Apr 24, 2026 at 6:15pm UTC
RESOLVED
CPS service continues to operate as normal. No further errors have been observed.
We continue to monitor the service.
Affected services
Updated
Apr 24, 2026 at 5:39pm UTC
No further errors have been observed after the service was restored.
We are continuing to monitor the service closely at this time.
Affected services
Updated
Apr 24, 2026 at 5:12pm UTC
The Cloud Payment Service has been restored and is now operating normally.
We will continue to monitor the service closely to ensure stability.
Affected services
Created
Apr 24, 2026 at 4:57pm UTC
We are currently investigating an issue affecting the Cloud Payment Service.
We are working to identify the root cause and will provide further updates as soon as more information becomes available.
Affected services