Back to overview
Degraded

MyPayter Portal Transaction reporting delay

Apr 24, 2026 at 9:48am UTC
Affected services
MyPayter

Resolved
Apr 24, 2026 at 11:17am UTC

The service has returned to normal operation and incident is closed

Updated
Apr 24, 2026 at 11:01am UTC

We are seeing transactions coming through the MyPayter Portal following the applied fix. We will continue to monitor the situation closely.

Updated
Apr 24, 2026 at 10:46am UTC

We have applied a fix and are seeing improvements, we continue to monitor the situation.

Created
Apr 24, 2026 at 9:48am UTC

We are investigating an issue with the MyPayter Portal causing a delay in transactions being reported.

This issue is currently impacting only the Apollo family of devices. We are working to resolve the problem as quickly as possible.