Back to overview
Degraded

MyPayter Portal Transaction reporting delay

Apr 22, 2026 at 1:53pm UTC
Affected services
MyPayter

Resolved
Apr 22, 2026 at 3:52pm UTC

Resolved.
The service has returned to normal operation.

Updated
Apr 22, 2026 at 2:56pm UTC

We have applied a fix and are seeing improvements, we continue to monitor the situation.

Created
Apr 22, 2026 at 1:53pm UTC

We are investigating an issue with the MyPayter Portal for a delay in transactions being reported.
We are working to fix the problem as quickly as we can.