Back to overview
Degraded

Confirmed CPS issue affecting terminal status updates

Apr 13, 2026 at 9:15am UTC
Affected services
Cloud Payment Service

Resolved
Apr 13, 2026 at 1:26pm UTC

Monitoring. A fix has been implemented and successfully resolved the issue for the affected terminals. We are continuing to monitor the system.

Created
Apr 13, 2026 at 9:15am UTC

We have identified an issue affecting our CPS service resulting in some terminals being unable to report their state. A fix is being implemented and improvements will be seen within the next hour.