Back to overview
Degraded
myPayter logins issue
Oct 17 at 11:32am CEST
Affected services
MyPayter
Resolved
Oct 17 at 11:42am CEST
Incident Resolved
The myPayter service is back in operational state.
Affected services
Created
Oct 17 at 11:32am CEST
We are currently investigating reports of the myPayter portal login failures and general performance issues.
Affected services