Back to overview
Degraded
Onomondo Degraded performance on 4G/LTE
Jul 28 at 02:37pm CEST
Affected services
SIM: Onomondo
Resolved
Jul 29 at 09:25am CEST
Update from Onomondo - All systems are stable, and traffic is back to normal levels.
Jul 28, 22:00 CEST
Affected services
SIM: Onomondo
Updated
Jul 28 at 03:55pm CEST
Onomondo upstream provider's upstream provider is having issues. Onomondo are waiting for an update from them. Jul 28, 15:27 CEST
Affected services
SIM: Onomondo
Created
Jul 28 at 02:37pm CEST
Onomondo are investigating the issue together with their upstream IPX provider. All LTE/4G authentication is currently disabled. Update by Onomondo on Jul 28, 2025 - 14:19 CEST.
We will keep you posted as we receive updates from Onomondo.
Affected services
SIM: Onomondo