Back to overview
Resolved

Potential CPS issue

Aug 12, 2026 at 9:31am UTC
Affected services
Cloud Payment Service

Resolved
Aug 12, 2026 at 10:02am UTC

RESOLVED: We have confirmed that all platform components impacted during the incident have recovered and service levels have returned to normal.

Created
Aug 12, 2026 at 9:31am UTC

Currently investigation potential ongoing issue with CPS service.